On behalf of the DocuSign Developer Center team, I am excited to announce a new release candidate version of our C# client library, DocuSign.eSign v3.0.0-rc. This version includes support for Microsoft .NET Standard 2.0, which enables you to integrate DocuSign eSignature functionality into your .NET Framework apps and also your .NET Core apps. It is now available for download on NuGet. Supporting .NET Core is one of our most requested features for our C# SDK, so we’re happy to be able to deliver on that request.

On a similar note, in case you weren’t aware, in the C# client library version 2.2.0 (so it is also included in this release candidate version), we addressed an issue when using JSON Web Tokens (JWT) authentication and you deploy web apps to Azure. You’d receive a cryptographic error on the ConfigureJwtAuthorization call because it required you to store your private key in a physical file. We added a new method, named ConfigureJwtAuthorizationFlowByKey, which enables you to pass the key value as a string instead and prevent the cryptographic error. You can store your private key in an Azure Key Vault or any other mechanism you choose.

We encourage you to try out this release candidate version and let us know what you think. The best way to give feedback is to create issues on our official GitHub C# Client page. Thanks to Bharat Rele on my team for adding .NET Standard 2.0 support to the DocuSign.eSign package.

Installing the DocuSign.eSign.dll package

You can install the DocuSign.eSign.dll package in one of these three ways:

  • Package Manager UI

When you browse for this release candidate version, make sure to enable the Include prerelease option, like this:

You can install the DocuSign.eSign.dll package in one of these three ways: Package Manager UI, Package Manager Console or .NET CLI

  • Package Manager Console
Install-Package DocuSign.eSign.dll -Version 3.0.0-rc
  • .NET CLI
dotnet add package DocuSign.eSign.dll --version 3.0.0-rc

Dependencies

Our C# client library v3.0.0-rc supports the following dependency library versions:

  • .NET Framework apps (>=4.5)
    • Json (>= 8.0.3)
    • BouncyCastle (>= 1.8.1)
    • RestSharpSigned (>=105.2.3)
    • IdentityModel.Tokens.Jwt (>=4.0.2.206221351)
  • .NET Core apps (2.0)
    • IdentityModel.Protocols (>=5.2.2)
    • Json (>=11.0.2)
    • BouncyCastle (>=1.8.2)
    • RestSharp (>=106.3.1)
    • ComponentModel.Annotations (>=4.5.0)
    • IdentityModel.Tokens.Jwt (>=5.2.2)

Sample code snippets

Useful links

By Naveen Gopala – Sr. Software Engineer – DocuSign